Seite 1 von 1

Server startet nicht

Verfasst: Freitag 15. März 2024, 20:46
von wschrewe
Der SVWS-Server startet nicht mehr bzw. wird sofort nach dem Start wieder beendet. Hat jemand eine Ahnung, woran das liegt? Mein Verdacht ist, dass das dienstägliche Windows-Update damit zu tun hat. Kann das sein?

Re: Server startet nicht

Verfasst: Samstag 16. März 2024, 11:08
von Raffenberg
Hallo Herr Schrewe,
läuft der Dienst nicht, oder kann Schild3 keine Verbindung aufbauen?

Re: Server startet nicht

Verfasst: Samstag 16. März 2024, 13:45
von wschrewe
Raffenberg hat geschrieben: Samstag 16. März 2024, 11:08läuft der Dienst nicht,
Der Dienst läuft nicht. Wenn ich ihn manuell starte, wird er nach kurzer Zeit, von wem auch immer, wieder gestoppt. Der Dienst für die MariaDB läuft einwandfrei.

Re: Server startet nicht

Verfasst: Samstag 16. März 2024, 23:49
von Raffenberg
Mhh. Bei mir läuft soweit alles (Windows 11 - 23H2). Ein Antivirenscanner würde ja Meldung geben. Liefert die Ereignisanzeige Hinweise (unter Ereignisanzeige - Windows Protokolle - Anwendungen)?

Re: Server startet nicht

Verfasst: Sonntag 17. März 2024, 22:55
von A. Schüller
Wird der Dienst nach dem Startversuch von SchILD3 gestoppt oder willkürlich nach einer gewissen Zeit?
Gibt es Hinweise im Log-File?:svws_server_service.out.log

Re: Server startet nicht

Verfasst: Sonntag 17. März 2024, 23:20
von wschrewe
Fehler gefunden und beseitigt. In der svwsconfig.json gab es (nachdem ich eine weitere DB migriert hatte) einen fehlerhaften Eintrag. Der Hinweis auf die Log-Dateien war sehr hilfreich.

Re: Server startet nicht

Verfasst: Montag 18. März 2024, 11:22
von wschrewe
Das Problem wurde ja, wie gesagt, durch einen fehlerhaften Eintrag in der Konfigurationsdatei verursacht. Aus meiner Sicht wäre es anwenderfreundlicher, wenn hier eine aussagekräftige Fehlermeldung erfolgen würde. Dass der Server in so einem Fall ohne weitere Rückmeldung insgesamt den Dienst quittiert, ist (für mich) doch etwas überraschend.

Re: Server startet nicht

Verfasst: Montag 18. März 2024, 12:34
von Raffenberg
Hallo Herr Schrewe. Ich leite die Idee an das Programmierteam weiter.

Re: Server startet nicht

Verfasst: Sonntag 21. September 2025, 13:44
von HvdB
Hallo zusammen!

Habe am Wochenende zum Testen auf unserem Schulserver den SVWS Server installiert, der Dienst will aber nicht starten. Die Migration der Datenbank ist durchgelaufen, aber in den Logs des Dienstes ist folgende Fehlermeldung zu finden:

Fehler beim Starten des Servers. Failed to bind to 0.0.0.0/0.0.0.0:443 SVWS Server wurde normal beendet.

Konkurrieren hier Dienste?

Schöne Grüße!

Hendryk von der Burg

@edit: Problem beim Formulieren der Nachricht erkannt und gelöst. Auf dem Server (MS Win 2022) lief der IIS Dienst. Erst nach Beenden des Dienstes startet auch der SVWS Server Dienst.

Re: Server startet nicht

Verfasst: Sonntag 21. September 2025, 15:21
von Frodermann
Port 443 ist ja der HTTPS-Port, das dürfte erstmal mit dem SVWS-Server als solchem nichts zu tun haben. Der Webclient greift über den Browser über https auf ihn zu, das dürfte hier ein Problem erzeugen?

0.0.0.0 ist eine IP-Adresse - aber eine, die nicht per Routing erreicht werden kann. Sie wird verwendet, um Host-Konflikte usw. zu erkennen.

Die MariaDB selbst läuft standardmäßig auf Port 3306.

Wenn der Port 443 irgendwie blockiert ist, könnte das an einer Firewall oder so liegen? Sind Sie auf einem Linux unterwegs? Dann könnte das hier helfen? Eventuell läuft da ein anderer Docker-Container?

https://serverfault.com/questions/61011 ... 0-0-0-0443

Abschluss des Posts: Jetzt erst den Edit-Vermerk gesehen. Diese Antwort ist nicht mehr notwendig, aber da wohl mit dem Problem verwandt, schicke ich Sie dennoch ab.